Surplus electronic parts : https://epartsconnect.com
Stock and Crypto AI Prediction : https://stocksignalslive.com

In this video I have a look at a 2010 Chevrolet 1500 Silverado that won't start. As a matter of fact it won't even crank now! Funny part is the fella drove it to my shop and it dies in my driveway. Ughh... -Enjoy!
If an SMA Video has helped you out please consider giving using "Patreon" to help support us. The videos take real time to create and pull us away from real work that pays our bills. CLICK HERE: https://www.patreon.com/southmainauto
CHECK OUT OUR "SMA SWAG" STORE! Go on Teespring and get your very own SMA merch!
https://teespring.com/stores/the-sma-store
If you don't like Patreon feel free to use the "PayPal Me" link: https://www.paypal.me/SouthMainAuto
The South Main Auto Amazon Store:
https://www.amazon.com/shop/southmainautorepairavoca
AES Wave Automotive Diagnostic Tools: https://www.aeswave.com/cart.php?m=affiliate_go&affiliateID=2525b91fc8e906e8215984074c9d9e8f&go=https://www.aeswave.com/Miscellaneous-p9347.html
Thank you for all the continuing support!
--Eric & Vanessa O.
Feel like sending some swag to SMA because you love the videos but don't know where to send it?
Just ship it here:
South Main Auto Repair
47 S. Main St
PO Box 471
Avoca, NY 14809
Disclaimer:
Due to factors beyond the control of South Main Auto Repair, it cannot guarantee against unauthorized modifications of this information, or improper use of this information. South Main Auto Repair assumes no liability for property damage or injury incurred as a result of any of the information contained in this video. South Main Auto Repair recommends safe practices when working with power tools, automotive lifts, lifting tools, jack stands, electrical equipment, blunt instruments, chemicals, lubricants, or any other tools or equipment seen or implied in this video. Due to factors beyond the control of South Main Auto Repair, no information contained in this video shall create any express or implied warranty or guarantee of any particular result. Any injury, damage or loss that may result from improper use of these tools, equipment, or the information contained

50 thoughts on “Chevy/gmc truck: no start – no crank”
  1. Avataaar/Circle Created with python_avatars Vic Vachon says:

    This worked for me!! Saved me big time!!

    I gotta put a comment and like in for this!!

  2. Avataaar/Circle Created with python_avatars TurnThemWheels says:

    What fuse was the 2 amp fuse

  3. Avataaar/Circle Created with python_avatars Michael Guziak says:

    THIS CHANNEL SEEMS TO BE THE BEST ON YOUTUBE I HAVE EVER FOUND. THANK YOU..

  4. Avataaar/Circle Created with python_avatars Michael Guziak says:

    》》 BEEN WORKING ON CARS SINCE 8 YEARS OLD. > CHEVY LINE MECHANIC. OWNED A COMMERCIAL PROPERTY AND AUTOMOTIV SHOP IN LOS ANGELES. SOLD I YEARS AGO.. AVIONICS MACHINIST NOW. NOW AT 70 YEARS OLD I CAN DO BRAKE JOB AND R & R A RADIATOR. ETC.ETC… ON MY 2000 CHEVY SUBURBAN.. BUT.. NOW TURN ON KEY. LIGHTS ARE ON DASH. NEW DIE HARD BATTERY. ENGINE WILL NOT START. TELLS ME KEY AND IGNITION SWITH IS OK. BATTERY TESTED. OK.. HOOKED UP LARGE WHEEL STYLE SHUMACHER BATTERY CHARGER. 200 AMP ENGINE START SYSTEM AND STILL NOTHING HAPPENS. SO.. CHEKED ALL ENGINE START FUSES..OK.. SWITHED ENGINE RELAY.. STILL NO START..》》 MY QUESTION IS… IS IT THE STARTER AND OR SOLONOID ?? OR DO I HAVE TO BUY EXPENSIVE SCAN TOOL OR JUST BUY $225.00 NEW STARTER & SOLONOID AT NAPA STORE. NAPA STORE GUYS HERE PRETTY SMART. THEY SAY IT SOUNDS LIKE THE STARTER..? HELP. TODAY IS THURSDAY MORNING. NO CAR TO DRIVE ME. I GUESS I HAVE TO GET A CAB TO NAPA. SOON I WILL HAVE TO OWN A SPARE CAR I GUESS. AUTO REPAIR THESE DAYS TOOOO EXPENSIVE.. MAYBE I BETTER GET A MOTORCYCLE TOOO. THAKS FOR ANY HELP..

  5. Avataaar/Circle Created with python_avatars Jayme Cuevas says:

    I am having a similar issue except, I have replaced the starter. When I initially replaced the starter, it turned over 3 consecutive times. The fourth time, landed me back to square 1.

    I thought the starter had gone bad and got it replaced through O'Reilly's. Turned out, when they tested it, it passed 3x using their Starter tester. They gave me a new one. Put the new one in, and nothing.

    Both the alternator and battery are good. I was thinking it may be a wiring issue but I've looked over and over and see no issue.

    *PS, spark plug, fuel pump, and all fuses and relays are good.

    Any help would be GREATLY appreciated.
    -2005 GMC Sierra 1500 5.3 V8 106k miles

  6. Avataaar/Circle Created with python_avatars Walter Bryan says:

    You saved me hours of jerking around – my 2amp fuse was toast too! Great video, clear explanations. Thank you so very much!

  7. Avataaar/Circle Created with python_avatars the Gonz says:

    Hey nerd! just kidding,your vids are great

  8. Avataaar/Circle Created with python_avatars dirty grizzly says:

    What scanner model is that autel your using?

  9. Avataaar/Circle Created with python_avatars Joe CNC says:

    Eric – I love your channel. The corrosion on the 2 Amp Fuse was the exact problem on my 2010 Chevy Silverado 1500 No Crank/No Start. My Fuse box looked very similar to your customer's, too. When I went to pull the 2 amp fuse out – the corrosion broke one leg of the fuse off in the panel!! I was able to remove the chunk by moving it side to side with a metal pick (Neg. Battery disconnected). Do you have any good ideas on cleaning the corrosion up inside those fuse holders? I'm thinking about rocking each one side to side, remove, then with a thin pick try to clean the corrosion up/down/side to side… Maybe hose it down with some electrical contact cleaner, let it dry thoroughly before replacing the fuse (legs cleaned with some scotch brite)?? Looking for a good idea here. Thank You for your channel, and your great videos. PS: I think its great to have your daughter working with you – shows her that money don't grow on trees, and dad works hard to put a roof over her head. Keep up the great work!!! YOU ROCK!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

  10. Avataaar/Circle Created with python_avatars Clint Peterson says:

    Had same problem relay

  11. Avataaar/Circle Created with python_avatars Irving F. Carrillo says:

    I have a similar issue. I don’t know if your fix is my fix but the way you diagnosed that was great and will definitely help me diagnose my 2500. Thank you!

  12. Avataaar/Circle Created with python_avatars Mike Gomez says:

    I watch your channel find it very useful at times well all the time actually my name us Mike iam from oroville ca I have a 2011 chevy silverado z71 4×4 with the 5.3 l fuel management that will drop down to 4 cylinder when other 4 are not in demand don't like that but that's a nother topic I had removed my wireing harness that feeds to the injectors and ignition coils think I might have some ground wires not I'm 5he right spots cause it won't start but all instrument symbols come on but no start also rhe color codes for injectors plugs wich gi to wich cylinder? I am homeless right now living out of my truck I trying to get back on the road others wiz I would if could donate contributions if you could help it would be extremely greatful

  13. Avataaar/Circle Created with python_avatars Fabian Quintana says:

    I I would like to ask if you can help out in finding out why my 2000 Tahoe won’t start no lights on dash turn on besides odometer battery and security light scanner reads ignition 1 inactive and trouble code b1477 thanks in advance

  14. Avataaar/Circle Created with python_avatars chavontez hawthorne says:

    I have a problem jus like this you mind giving me pointers on how to go from here I have changed everything stater alternator spark plugs and it’s still not getting any fire it currently only reads 11 volts on the battery gauge no matter if I charge the battery or get a new it stay the same voltage I jus don’t know what to do from here and I did put a cam on it and had it tuned it’s a 2008 gmc seirra jus any opinion you have would be great thank you

  15. Avataaar/Circle Created with python_avatars Wayne Daudelin says:

    Great job my 2012 GMC just did this to me my thinking it's the safety switch but it's not on the transmission I think its up at the steering column. I hope that's the problem of why it doesn't start

  16. Avataaar/Circle Created with python_avatars Dean Wilson says:

    Great video! I’m having trouble with a 2013 Tahoe. Wipers will not work, I hear the relay clicking. I changed the wiper motor but still not working?!

  17. Avataaar/Circle Created with python_avatars Michael Barrera says:

    Yooo you are a life saver I was having the same problem and was breaking my head and you were right I have the same problem it was the 2amp fuse the whole time

  18. Avataaar/Circle Created with python_avatars Old Scout says:

    HELP I can’t get fuse box lid open ( under the hood). Please help, no start, no crank, trying to check fuse .

  19. Avataaar/Circle Created with python_avatars Vern Toad says:

    I still wish you were in Wisconsin

  20. Avataaar/Circle Created with python_avatars Michael Glanville says:

    Great stuff, this helps a lot sat on the edge of my seat. Yes am working on 95 chevy suburban and yes this helps a lot, time to paint eyes on this monster

  21. Avataaar/Circle Created with python_avatars timkiddsr says:

    South Main Auto is amazing ,I was in the same situation for about 2 weeks ago . I was pull my hair I dont have a scanner to read so I starting probing the fuse box and the answer came with a crusty fuse and it was the 2 amp I am so thankful for you. I was almost in tears .I was ready to give up it died the same way . I f I could afford it I would send you a $100 just for working on someone's car.

  22. Avataaar/Circle Created with python_avatars Chris Garcia says:

    I just checked a 2013 Tahoe that was doing the same. Dead battery and wouldn't start after jumping. I removed that fuse and all the fuses relating to the ecm and ign. It started but shut off after a couple of minutes. I asked customer to get a new battery first and I will check amperage on those fuses. Subscribed for sure. 😎

  23. Avataaar/Circle Created with python_avatars Brian Sumner says:

    Very well done Sir. I watched the whole vid as I am dealing with an intermittent no crank no start situation. I will check all my fuses. Thx.

  24. Avataaar/Circle Created with python_avatars randall anthony says:

    how is this suppose to help

  25. Avataaar/Circle Created with python_avatars david blizzy says:

    I did the test light on all my fuses in the fuse box and all them had no power but tested them with the ohmmeter and they were all good Any idea why the fuse box wouldn’t be getting power? Car won’t crank only one driver headlight works breaks work no horn no power windows and no alarm beep with I lock my truck with my key? 2016 Silverado

  26. Avataaar/Circle Created with python_avatars George Thamos says:

    Good find but my guess is the owner will not want the expense of replacing the TIPM.

  27. Avataaar/Circle Created with python_avatars Derick Trx says:

    Oh my the way I’m working on a 2500 hd 6.0 gas that’s having a problem. It cranks over but not starting. It was starting and running for a few minutes. Then it would just quit as if the key was turned off. No start…. Now. Can you get me any advice? Thanks Derick

  28. Avataaar/Circle Created with python_avatars Derick Trx says:

    Did you charge him for the fix. You worked on his truck for sometime. In changing of that bad fuse. Just wondering how must it cost him…. And did you ever do the oil sensor job?

  29. Avataaar/Circle Created with python_avatars Chris Johnson says:

    This same thing has been happening to my 2008 Silverado since this summer when I had a new engine put in. Every couple of days it just decides it will not start. I pulled the same 2 amp fuse you did and mine was the same corrosion. However, replacing it did not fix the issue, my truck is still sittting here in the parking lot at my work. Any other help or suggestions would be great.

  30. Avataaar/Circle Created with python_avatars Felicia Auld says:

    hello can you help us We have a Cadillac Escalade 2007 and I’m only getting ground to half of my fuse panel and I have no start and lights up on my dash though .Mostly towards the windshield Are the fuses not working also have no park or drive light up on our dash everything else lights up though

  31. Avataaar/Circle Created with python_avatars John Makuk says:

    Great video.
    I like your personality, straightforward and not like some school teacher!

  32. Avataaar/Circle Created with python_avatars Tony Bruce says:

    I have a 1996 Chevy K1500. Starts and runs fine. But when it gets hot it likes to stall out when I come to a stop. Not really sure what the problem is. Little help would be nice. I don’t want to just throw parts at it. It has a 350 now. Was a 305, but it did the same thing before the head casket blew. Cheaper to change the engine. It doesn’t throw any codes. Thanks.

  33. Avataaar/Circle Created with python_avatars Michael Angelo Diaz Jr says:

    My 2007 gmc Sierra has same issue, out of nowhere won’t start. It’s sitting in the middle of the the pasture at the moment. Going to check those fuses

  34. Avataaar/Circle Created with python_avatars Devin Bounking says:

    Help!!!! No voltage on gauge no start

  35. Avataaar/Circle Created with python_avatars Devin Bounking says:

    Watch your channel and it’s awesome

  36. Avataaar/Circle Created with python_avatars Devin Bounking says:

    Have same problem with my 07 tahoe……I check that 2 amp fuse seen not blown….but will check again. I’m having it towed home today to do a thorough check…

  37. Avataaar/Circle Created with python_avatars Cole says:

    Im going to try this out with my truck tomorrow, if this is the issue I owe you one for sure. Thanks for the vid

  38. Avataaar/Circle Created with python_avatars Coley Cole says:

    What model scan tool is this?. I'm having similar intermittent problems and that is would be helpful by myself.

  39. Avataaar/Circle Created with python_avatars Brent Mohlman says:

    I have a question have a 2000 Chevy Silverado truck ran just fine was parked went to go start it would not start someone said something about it might be the cluster took the cluster out sent it out to have them fix it they never did say what was wrong with it or if anything was wrong with it sent it back put it back in no different mind you it ran just fine before all this I'm thinking something very simple but I don't know nothing about this also I looked up ran a wire from the fuse box and touch it on the red main wire when the ignition is on on and it will start I watch some of your videos you are very intelligent with this stuff let me know if you might know what it might be thank you and keep up all good videos

  40. Avataaar/Circle Created with python_avatars gjurczyc says:

    Maybe it went for a swim

  41. Avataaar/Circle Created with python_avatars John Adams says:

    Nice work, helpful

  42. Avataaar/Circle Created with python_avatars Mike Castleberry says:

    Drive in high water and you get crustys. Bingo

  43. Avataaar/Circle Created with python_avatars Midian Alberto Khaiyow says:

    hi, What is the name of the program where you get the electrical schematics?

  44. Avataaar/Circle Created with python_avatars Mary Pete says:

    My 2010 GMC Sierra is going a similar thing! I'm gonna check fuses tomorrow.

  45. Avataaar/Circle Created with python_avatars James Hill says:

    I’m not a mechanic but I’m trying to learn more to work on my 2014 gmc Serra. Having the same issue intermittently. Thanks for this video. Learn something new everytime I watch your video.

  46. Avataaar/Circle Created with python_avatars Doug Sanders says:

    Got this truck at a bargain price, only to find out it's been under water. Oh! And the fuse box lid had to be replaced, because the other one floated off. Beware of stealerships.

  47. Avataaar/Circle Created with python_avatars Bill Suffolk says:

    Thanks so much my friend, my 2007 Tahoe did the same thing to me today and thank god for your video, I watched it and went outside and found the same 2 amp fuse was bad !! replaced and my truck started right up !!! Thank you so very much for the super video !! You Rock

  48. Avataaar/Circle Created with python_avatars Rogers Derek says:

    How much you charger to come out

  49. Avataaar/Circle Created with python_avatars twwtb says:

    And the rust under those vehicles.