Surplus electronic parts : https://epartsconnect.com
Stock and Crypto AI Prediction : https://stocksignalslive.com

Let's have a go at this 2007 Chrysler Town and Country that has an engine light on with a code P0480. Pretty classic problem on these beasts and I'll show you how I diagnose these cooling fans.
Cool rivet gun huh? Want one? Look here : http://astore.amazon.com/httpswwwy0837-20/detail/B000MQ9H4W'>http://astore.amazon.com/httpswwwy0837-20/detail/B000MQ9H4W
Interested in stuff seen in the videos or the tools and toys Eric O. likes and uses? Check out the **ALL NEW** SMA A-Store and help support the channel! : http://astore.amazon.com/httpswwwy0837-20
If an SMA Video has helped you out please consider giving using the "support" link on our YouTube home page. The videos take real time to create and pull us away from real work that pays our bills.
THANKS!
--Eric O.
WANT AN "SMA" STICKER OF YOUR OWN!?!
Simply send and E-mail to SMAstickers @outlook.com including: your shipping address and e-mail address in the text, I in turn will send you a paypal invoice for $5 each USA or $6 each international. Let me know how many you want and as soon as the paypal invoice is paid I will ship them out ASAP! Thanks for your support of our channel!!
--Eric & Vanessa O.
Feel like sending some swag to SMA because you love the videos but don't know where to send it?
Just ship it here:
South Main Auto Repair
47 S. Main St
PO Box 471
Avoca, NY 14809
Disclaimer:
Due to factors beyond the control of South Main Auto Repair, it cannot guarantee against unauthorized modifications of this information, or improper use of this information. South Main Auto Repair assumes no liability for property damage or injury incurred as a result of any of the information contained in this video. South Main Auto Repair recommends safe practices when working with power tools, automotive lifts, lifting tools, jack stands, electrical equipment, blunt instruments, chemicals, lubricants, or any other tools or equipment seen or implied in this video. Due to factors beyond the control of South Main Auto Repair, no information contained in this video shall create any express or implied warranty or guarantee of any particular result. Any injury, damage or loss that may result from improper use of these tools, equipment, or the information contained in this video is the sole responsibility of the user and not South Main Auto Repair.

50 thoughts on “Chrysler town country / caravan – p0480 cooling fan trouble”
  1. Avataaar/Circle Created with python_avatars Izzynutz Restorations says:

    Hey Eric I have a 2006 Chrysler Town and Country Touring with a 3.8 but just started having a problem today I live in Florida and if I'm sitting in traffic like waiting on a light or something my idle is very low and then all the sudden my idol will kick up and the battery light will come on I pull over and check it and the fans are just barely running then I will shut the vehicle off leave it set for five or so minutes and start it back up the battery light is off the fans do not run and if I leave it sit there an idol when it goes to command the fans on the fans move just a little bit it starts running wonkie, and the idle pops up the battery light comes on and the fans start running in low speed I'm going to change that module out I think it's pulling down the voltage trying to start the fans the system can't handle it shuts down the voltage enabling the battery light

  2. Avataaar/Circle Created with python_avatars krystal robie says:

    hi steve love the show i have a 2012 dodge caliber sxt im getting code p0480 i have replaced a relay as there was corrosion and still nothing i have jumped power from the battery and the fan does work and i can spin the fan by hand and i do not see a radiator fan relay so i was hoping that you may have som insight on this? im planning on going through the wiring harness to see how the wires look and go from there. fyi i sent a comment about this from my tablet but was not sure if it got to where its going or i did it right.

  3. Avataaar/Circle Created with python_avatars Kenneth Tallman says:

    Hey Steve love you show question I got a 2012 Dodge caliber SXT I'm getting a code for a p0480 it says cooling fan one control circuit problem is can't find the control circuit nobody seems to know I was wondering if you would run into any of these vehicles with that and as far as I can tell it doesn't have a radiator relay radiator fan relay I replaced one of the mini relays for the cooling fan cuz it was corroded I'm not sure I have jumped the fan motor from the battery and it does work it free spins by hands I just wondered if you had any insight on that

  4. Avataaar/Circle Created with python_avatars J Craddock says:

    Yup that was my problem on 2005 Chrysler Town & Country 3.3L engine thanks👍🏽

  5. Avataaar/Circle Created with python_avatars justin valdex says:

    So I just did exactly as you did but when I went to run the ac with the probe in the light never came on but the fans will both turn on if I have the relay plugged in with the ac running ? Kind of stumped right now I tried replacing the relay and as soon as I drove it engine light came right back on

  6. Avataaar/Circle Created with python_avatars Joe Z says:

    Ford focus same code 0480 which i already ordered the part , but now i know how to check the wire functions with my old trusty test light

  7. Avataaar/Circle Created with python_avatars Efrain Rivera says:

    My cooling relay on my dodge grand caravan is located in an easy spot I got wondering and found by part number on relay ordered one just in case thanks watch you all the time

  8. Avataaar/Circle Created with python_avatars Rodney Dunnigan says:

    My fan stays on too long thinking it's the relay by the grille

  9. Avataaar/Circle Created with python_avatars hamradio Ham says:

    literally the same for 2005 pacficia , my fans come on when temp is 1/4 way in the scale, not even 1/2 way , so im replacing the fan relay, already checks and replaced the fuse for it in fuse box #13

  10. Avataaar/Circle Created with python_avatars Bernarda Flores says:

    Thanks for making this video, I'll add a clip to my arsenal parts to bypass it if I have a problem on the road.

  11. Avataaar/Circle Created with python_avatars TypeR Spex says:

    Can the damage fan resistor caused the cooling fan not to work or not on a vauxhall corsa

  12. Avataaar/Circle Created with python_avatars Antonio Claudio Michael says:

    Super easy fix Just a Cooling Fan Relay and Not too hard good Video Eric O @SouthMainAutoRepairLLC

  13. Avataaar/Circle Created with python_avatars Jasper Nemesio says:

    Well my Colling fan on my 2012 t&c will not come on unless the AC is on.

    It was giving me a Low Fan Circuit Low code before but I unplugged the cooling fan resistor and adjusted the gap on the connector pins and now the fan comes on only when the temperature gauge is to about a quarter but then when it gets to 204f the coolant reservoir starts bubbling and it starts to overheat and the fan never does come on again

    I'm guessing it's gonna be the computer.

    I have a snap on versus and so I'm able to turn on the low and high fan with it but what's weird is that if I turn on the fan through the TIMP module, both low and high speed work the way they should, but when I command the Low Speed/Cooling Fan Relay#1 on, the high speed fan comes on. So that's why I'm assuming it's a bad computer. Does anybody have this issue?

  14. Avataaar/Circle Created with python_avatars Shea Holt says:

    If I turn my ac on and fan works does that mean the relay is still good and will come on when motor gets hot

  15. Avataaar/Circle Created with python_avatars Troy A. Summers says:

    You do know that is a resistor not a relay correct? Just saying

  16. Avataaar/Circle Created with python_avatars Joe Billard says:

    Hey not sure if you can help me. I have the same van. My fans come on with the A/C but they are on low speed and do not want to go higer. The compressor starts to overheat from high condenser pressure what should I look at next

  17. Avataaar/Circle Created with python_avatars Luba Luba says:

    Can I visually see if the AC fan is on or off because my car only cools off when I am driving or moving when I stop doesn’t work really.

  18. Avataaar/Circle Created with python_avatars Glenn Beal says:

    I know this is an older video on a Chrysler T&C with cooling fan issues, but in the spirit of SMA helping DYI folks, I'll pass along my story… a while back my wife pulled up in the driveway in her 2013 T&C with the high speed fan running (I could hear it from down the street), which was odd for the temp that day and that she wasn't in traffic. I found it was throwing the P0480 Cooling Fan 1 Control Circuit/Open code. I used my diag tool to clear the P0480 code and then used the tool to actuate Low speed Fan 1. This immediately started High speed Fan 2 and threw the P0480 Cooling Fan 1 Control Circuit/Open code. I assumed this wouldn't solve the issue, but for shits and giggles, I changed out the low speed fan resistor and the low speed fan relay in the TIPM (because it was quick… yeah, I'm lazy)… but no luck. I'm sure many of you are not surprised that the issue was caused by the TIPM itself, which I R&R'd and solved the problem. The driver circuit for the Low Speed Fan relay is likely at fault. I kept the old one to see if I could find and resolve the issue. I know… get a life

  19. Avataaar/Circle Created with python_avatars Nugget says:

    What's great about this is that you test your wires also to the PCM, so you can rule them out as being bad using this method. If this works, and your relay doesn't, then you know the harness connector isn't connecting or the relay is bad.

  20. Avataaar/Circle Created with python_avatars Hussain Shatwan says:

    My car I chang the fan electric ⚡ valve new one when the temperature 🌡️ it in the half the fan not working when I remove the plug 🔌 the fan will working what is the problem do you think please

  21. Avataaar/Circle Created with python_avatars Nash Channel says:

    My problem is the cooling fan is on all the time. Turn the van off pull the keys and the fans are still running. I replaced the relay but that didn't take care of the problem. Any suggestions?

  22. Avataaar/Circle Created with python_avatars Dan Escobar says:

    what if there is no signal coming from the control wire?

  23. Avataaar/Circle Created with python_avatars Matt Grafton says:

    What do I do if the 40 amp fuse for the radiator fans keeps blowing out when I turn on the blower for the AC? Constant power is good, constant ground is good, but the modulating power is not working

  24. Avataaar/Circle Created with python_avatars Dave Torres says:

    Question, i replaced the solenoid and still the fans dont work, im thinking a fuse or relay, but have no luck in locating either on the van, can you help me please?

  25. Avataaar/Circle Created with python_avatars JORDY FORTY says:

    i have same problem with 06 Chrysler coolant fan not turning on replaced relay. an still wont turn on

  26. Avataaar/Circle Created with python_avatars Mitch Dante says:

    Hi Thank you for getting me on the right track! 2014 caravan. Running hot in idle traffic only, gauge goes to 3/4 high. Then still in traffic the gauge drops to half, and I start traveling again and the gauge goes back to just below 1/2. I just had the thermostat replaced, didnt fix it!
    QUESTION PLEASE! It seems my fan doesnt come on until the engine gauge is 3/4 up. Then the fan kicks on and the temp gauge goes to half then just below half. WHat do you think?

  27. Avataaar/Circle Created with python_avatars John Murphy says:

    Another great vid Eric. Your a legend ,fella.

  28. Avataaar/Circle Created with python_avatars Eugene Butler says:

    So if I turn my ac on and the fans don't kick on.. that means the fans are bad?
    Or the relay is bad…
    My 2001 dodge caravan is over heating when idle in drive through and stores…
    Been browsing the web trying to find a fix..

  29. Avataaar/Circle Created with python_avatars Lucas Mclaurin says:

    How did you get it to flash the code like that? That was cool

  30. Avataaar/Circle Created with python_avatars Ted Thornton says:

    Daughter's 03 , 3 3, Caravan. Replaced Brake Master Cylinder due to pedal sink started car drove 1/4 mile left front brake was dragging, replaced front left caliper( old one stuck wore out pad damaged caliper)both front brake pads, drove 1 mile gased up with engine off, restarted drove back 1 mile. Next day bled all wheel cylinders with engine off. Then crank but no start. Codes 118, 123, 508, 509, 1193. All codes were present on old pcm and now on new one. Replaced Crankshaft position sensor, tps sensor, coilpack, coilpack connector, spark plugs , pcm.Gotta iod parasitic draw. Remove iat fuse draw disappears, returns when fuse reinserted. IAT clicks when fuse is reinserted and sometimes radiator runs briefly simultaneously then quits within seconds. Antitheft light doesnt come on , never. Not with key in start position, not when arming alarm with fob or key. New batteries in fob, tried 2 different keys. Tried charging batteries, tried different battery , tried jumping . All fuses good, all fuse hot legs above 12 volt except IOD. ASD clicks with key in run position. Fuel pump runs a few secs when key in run position. Lights will blink mysteriously sometimes. It Did this before new pcm and now does it with new one. Reset computer several times. Help a brother Eric.

  31. Avataaar/Circle Created with python_avatars Ted Thornton says:

    Better than government work Eric. Getter done son.

  32. Avataaar/Circle Created with python_avatars EliteN3rd- 86 says:

    Hey man. I have an issue with my 2006 Toyota Sienna van. when I bought it I noticed that the cooling fans were not engaging except for if I turn on the air conditioner. I found out that cooling fan module was around $270, so I decided to try to bypass that control box at the cooling fan relay. Me having limited knowledge, I removed the cooling fan relay and ran a jumper wire between terminals and at that point I saw a spark. From then on, my cooling fans don't work at all and my air conditioner controls inside don't work, no display and doesn't even blow and airbag light is on… Any suggestions where to start? Fuse link? Tia

  33. Avataaar/Circle Created with python_avatars MostlymoparIH says:

    Okay so I'm working on a 99 Caravan and while the colors are different and the relay is on the frame and not in front of the radiator your testing procedure has worked so far.
    I get to the part where you start the car and turn the AC on and just like in your video my light does not come on. You move the probe and get a good connection and your light came on. Well I moved my probe around also but alas no light. Looking at the wiring diagram I have it shows the line going to the fans. If you apply 12 volts to the fans they turn. I have replaced the relay and it did not fix the problem. Initial problem was the fans were on constantly but did not turn off and I disconnected the battery to turn them off. When I reconnected the battery the fans did not come on but the next day the battery was dead. I also replace the thermostat and temperature sensor. My diagram says position 3 is for fan output and that is the line that does not turn on when you start the engine and turn on the AC.Your video is very good and I appreciate your using the scope on a rope it has gotten me further in my diagnosis.

  34. Avataaar/Circle Created with python_avatars coin slots and joysticks says:

    After you take the 6 screws out on the top your to the sensor you don't have to take the headlight out

  35. Avataaar/Circle Created with python_avatars david griffiths says:

    I bought a cheap test light. Did step by step with Eric on the video. I needed a relay. changed it as if I knew what I was doing. Thanks!!!

  36. Avataaar/Circle Created with python_avatars The Alchemist 666 says:

    Only one of the fans is working, the second one does not come on, Do u think I need a new set of fans

  37. Avataaar/Circle Created with python_avatars leesa trudeau says:

    I let a person borrow my 2005 Dodge Ram 1500 4.7 lt Magnum V8 and the fan blade flew off into the radiator. * Advice don't lend your vehicle out if you don't know the person very well * Anyways a couple months before that my ex got into a rear end collision so I no longer have a cooling fan control circuit or the wires that should be there. Now I don't have A/C or heat. I was wondering if there was a way to get around not replacing it all. TY for your time.

  38. Avataaar/Circle Created with python_avatars lucas pallan says:

    Only one fan works. What’s that mean

  39. Avataaar/Circle Created with python_avatars Ken says:

    I don't get 12v on the Orange wire to ground. I tried a jumper between the Orange and Blue with no luck. If I connect from the battery to the Blue wire the Fans come on.
    Could you give me a tip where to trouble shoot next. I am temped to get a switch and manually turn on the fans but would like to see what else could be the problem. Thank you

  40. Avataaar/Circle Created with python_avatars Juan Pendon says:

    I got a problem on my dodge caliber 2008 sxt horn not working . I connect 12V to the horn and it work fine. I can’t find the horn relay. Can you help me about this. Thanks.

  41. Avataaar/Circle Created with python_avatars Jeff Frost says:

    I have a 2013 ram CV van cooling fan come on when warm but then will not shut off do you shut the key off everything seems to check out but the check engine light stays on with this existing problem the same thing happens with the AC relay is good motor seems to run well.I can't find any confirmation that it uses a fan control module I don't think it does. Thank you for feedback

  42. Avataaar/Circle Created with python_avatars Veghead says:

    2004 Grand Caravan. My AC stopped blowing cool. Radiators fans not turning on. Would replacing this relay allow cold air ? I hear compressor turning on. Isn’t overheating unless I’m in city. I do see some overflow. But temperature is good.

  43. Avataaar/Circle Created with python_avatars 56v12cylinder says:

    if i get the trouble code PO480 (on my t & c 2005) can i just presume that its the relay without having to test it?