Surplus electronic parts : https://epartsconnect.com
Stock and Crypto AI Prediction : https://stocksignalslive.com

In this video I show you how to diagnose a bad ignition switch in a 2001 GMC Jimmy that is creating an intermittent no spark condition causing the vehicle to crank but not start.
*Professional 6-12V Circuit Tester - Indicator Light - Lifetime Warranty by Industrial Tools:https://amzn.to/2JOgxGg
Ignition Switch:
BWD Part No. CS658
Here is the video with the fix: https://www.youtube.com/watch?v=TXKp3UEXnUQ
If an SMA Video has helped you out please consider giving using "Patreon" to help support us. The videos take real time to create and pull us away from real work that pays our bills. CLICK HERE: https://www.patreon.com/southmainauto
THANKS A MILLION!!
--Eric O.
If you don't like Patreon feel free to use the "PayPal Me" link: https://www.paypal.me/SouthMainAuto
The South Main Auto Amazon Store: https://www.amazon.com/shop/southmainautorepairavoca
AES Wave Automotive Diagnostic Tools: https://www.aeswave.com/cart.php?m=affiliate_go&affiliateID=2525b91fc8e906e8215984074c9d9e8f&go=
WANT AN "SMA" STICKER OF YOUR OWN!?!
Simply send and E-mail to SMAstickers @outlook.com including: your shipping address and e-mail address in the text, I in turn will send you a Paypal invoice for $5 each USA or $6 each international. Let me know how many you want and as soon as the Paypal invoice is paid I will ship them out ASAP! Thanks for your support of our channel!!
--Eric & Vanessa O.
Feel like sending some swag to SMA because you love the videos but don't know where to send it?
Just ship it here:
South Main Auto Repair
47 S. Main St
PO Box 471
Avoca, NY 14809
Disclaimer:
Due to factors beyond the control of South Main Auto Repair, it cannot guarantee against unauthorized modifications of this information, or improper use of this information. South Main Auto Repair assumes no liability for property damage or injury incurred as a result of any of the information contained in this video. South Main Auto Repair recommends safe practices when working with power tools, automotive lifts, lifting tools, jack stands, electrical equipment, blunt instruments, chemicals, lubricants, or any other tools or equipment seen or implied in this video. Due to factors beyond the control of South Main Auto Repair, no information contained in this video shall create any express or implied warranty or guarantee of any particular result. Any injury, damage or loss that may result from improper use of these tools, equipment, or the information contained in this video is the sole responsibility of the user and not South Main Auto Repair

48 thoughts on “No start / no spark / cranks ok – gmc jimmy / s10 blazer”
  1. Avataaar/Circle Created with python_avatars karma says:

    If the red wire is off . Shows no light. Even went is cranking. But pink wire is on all the time . Still is the ignition switch?

  2. Avataaar/Circle Created with python_avatars Troy Harris says:

    Well done..clear,concise and professional.

  3. Avataaar/Circle Created with python_avatars Ricardo Kern says:

    Thanks!

  4. Avataaar/Circle Created with python_avatars Leif Nilsen says:

    Thank you…….working on this problem right now

  5. Avataaar/Circle Created with python_avatars Mike Hunt says:

    Thank you for posting this video I never thought to check the 15 amp fuse and because of this video I got my truck started thank you.

  6. Avataaar/Circle Created with python_avatars Hunter Lee says:

    Wondering if you can help? 2006 silverado 1500hd 6.0 overnight start in morning crank no start some popping in exhaust until 2nd try runs flawlessly, also turn key off 1min turn key on for 2 min crank no start some popping in exhaust until second try runs flawlessly. Replaced cam position sensor due to code being set, did it before changing out, crank speed shows good, 55/60 psi fuel pressure, passlock good, injectors are pulsing, no spark on start attempts

  7. Avataaar/Circle Created with python_avatars Bilmar cervantes says:

    I have the same problem but on a 2004 Silverado 4.3 but it’s blowing a fuse you think it’s a bad ignition control module?

  8. Avataaar/Circle Created with python_avatars Richard Fondren says:

    Sure hope I can start searching YouTube videos again

  9. Avataaar/Circle Created with python_avatars Geo M. says:

    Hey eric hope all is well. Have a weird issue. Have an older Chevy Express 5.0 VIN M . I left NYC for about one year and two months, when I left the van was running no issues at all. I came back last month Feb.22022, during that period the van sat basically on the street and battery was disconnected. I changed the oil went to start the engine and nothing, just cranks and cranks. I suspected it was the fuel pump and heard no priming when opening the key. The weird issue is that I disconnected ECM fuse B under the hood and plugged it back in and the dash check engine light would flash on and off, at the same time as the fuel pump.. so it cycled on and off on and off and wouldnt stop. The other weird part is there is no spark, i bought an ICM , coil and still no spark. The van was running before I left, it was bot touched or started so i thought maybe mice but cant find anything chewed up. I manually powered the oump with a power probe and pump runs. Not sure either if this year had factory alarm but I dont think so since the dash has never shown me any security lights. I am stumped and dont want to throw parts at it, i was the thinking maybe the crank position sensor… would you have any ideas

    My biggest worry is why would the fuel pump cycle on and off continuously and at the same time, the check engine light would flash on and off. Thanks hope you read this.

  10. Avataaar/Circle Created with python_avatars Joe Cody says:

    Hello,to sth main auto like ur works,Like watching your videos,,from Cody..

  11. Avataaar/Circle Created with python_avatars Rich Headd says:

    I like having people like you around

  12. Avataaar/Circle Created with python_avatars Chris Dembowski says:

    Thanks bro great. Flick as always

  13. Avataaar/Circle Created with python_avatars Ralph Vaccaro says:

    Your the Man

  14. Avataaar/Circle Created with python_avatars Antonio Claudio Michael says:

    Nice diag and diagnostic testing Good old test light got it to crank and start good work Eric O @SouthMainAutoRepairLLC

  15. Avataaar/Circle Created with python_avatars Antonio Claudio Michael says:

    Very unusual problem power to coil only after cranking stops Hmmm intriguing 🤔 Eric O @SouthMainAutoRepairLLC

  16. Avataaar/Circle Created with python_avatars Antonio Claudio Michael says:

    Love these Older Videos Eric O and You Have Come Along Way From the Shyness From these back in the day videos To now Always great work @SouthMainAutoRepairLLC

  17. Avataaar/Circle Created with python_avatars Trey Slay says:

    Nice by pass gonna try dat

  18. Avataaar/Circle Created with python_avatars Trey Slay says:

    My 96 tahoe may have this problem it got hit on the driver side by the ecu ignition cm is making a noise it cranked up after crash now Nonthing got 2 do some wire testing it could b a number of things what's your guess??

  19. Avataaar/Circle Created with python_avatars Scooters Only Repair says:

    That's the fuse I'd pull out while storing my vehicle to prevent theft.

  20. Avataaar/Circle Created with python_avatars Kolton Neil says:

    Hey Eric, great job on both videos! I am having the same issue on the exact same truck. All symptoms were identical, I swapped out the switch and still not starting. Any other possible routes to look into?

  21. Avataaar/Circle Created with python_avatars Brian Staude says:

    Great job. I have been lucky, throw a cap & rotor at it {a number of times} and roll. I'll be back to watch this again when it catches me. Thanx!

  22. Avataaar/Circle Created with python_avatars sledgenwedge says:

    I can tell you this much if the oil pressure sensor is malfunctioning it will not register to the computer and turn on the fuel pump. You'll get starter turning over spark but no fuel

  23. Avataaar/Circle Created with python_avatars Roger Haines says:

    Very thorough thanks

  24. Avataaar/Circle Created with python_avatars David_BMX1 1 says:

    I have 1999 S10 no spark can't here fuel pump kicking on replaced cam sensor cap rotor coil crankshaft sensor control module please help????

  25. Avataaar/Circle Created with python_avatars lifeathand says:

    Great video a true mechanic not just a parts changer

  26. Avataaar/Circle Created with python_avatars eliud lopez says:

    Very cool stuff

  27. Avataaar/Circle Created with python_avatars Jor arr says:

    Good job

  28. Avataaar/Circle Created with python_avatars F. Perry says:

    Hello I got a similar problem but in my case it's a 2000 Chevy S10. The same fuse (ecm 1) keeps blowing every time you turn the ignition on. Background, I just had a new set of injectors installed as well as a new fuel pump installed. Afterwards the truck ran but idle real high I'm talkin take your foot off the brake in drive and the truck starts doing 10 miles an hour on its own. Another fellow and I were looking over the engine to see if we could figure out why it was idling so high he put his hand over the intake and his hand got stuck down on it and it took the engine off. Now the truck will not start it turns over but just not crank up. Thanks to your video I Fount the blown fuse unfortunately that fuse keeps blowing every time I turn the ignition key on. Any ideas?

  29. Avataaar/Circle Created with python_avatars Roberto Huizar says:

    on my truck the problem was the ignition relay

  30. Avataaar/Circle Created with python_avatars M B says:

    My 1988 Chevy S10 4 cylnder is doing the same thing, all I can say is you are the MAN, Thank you very much good diagnostic skills and Thank you for sharing the problem and solution.

  31. Avataaar/Circle Created with python_avatars Donald Petrey says:

    Great vid and great step by step troubleshooting. One of the best vids by far 100% awesome.

  32. Avataaar/Circle Created with python_avatars Dan Fogg says:

    The Funniest thing about this is my 99 Blazer is doing similar to the same thing. Now I'm just going to do the same test that they did on the video

  33. Avataaar/Circle Created with python_avatars Dan Fogg says:

    That's great. It's good to see actual mechanics still working correctly. There's to many part's replacers out there.

  34. Avataaar/Circle Created with python_avatars G McNelly says:

    Always check the box before you leave or let the delivery driver leave. I learnt my lesson the hard way!

  35. Avataaar/Circle Created with python_avatars John E. Carr says:

    Another great video.

  36. Avataaar/Circle Created with python_avatars John E. Carr says:

    Another great video.

  37. Avataaar/Circle Created with python_avatars Dan Spears says:

    Having the same problem with a 98 s10 blazer. Just replaced the ignition switch. Still not starting. Any suggestions?

  38. Avataaar/Circle Created with python_avatars likescars says:

    I have voltage at the coil but no spark, does that mean for sure the coil is bad or could there be another test I should do? Thanks

  39. Avataaar/Circle Created with python_avatars Hola! Jack Mohabir says:

    You are a great , smart , affable mechanic.
    Good job , Maestro!

  40. Avataaar/Circle Created with python_avatars Wayne says:

    Excellent. Very helpful framework for many situations. Thank you

  41. Avataaar/Circle Created with python_avatars Rush Galt says:

    I wish you could help….I can't get my 3 s-10 to start… it's trying to, but can't.

  42. Avataaar/Circle Created with python_avatars Kenneth Burnett says:

    Got a question about my 96 s10 truck when I skan the truck I get a reading it cant read the mass air so I put a new one in an scanned it agin an the same have any ideas

  43. Avataaar/Circle Created with python_avatars James Maddox says:

    Has anyone had problems with the ignition relay mounted on the firewall killing spark from the ignition coil. Ruled out coil, coil wire, ignition module, and ECM, by swapping known good parts from running spare blazer. Haven't found wiring diagram in Haynes for the ignition relay. Just slept and came to me to check relays. Had actually unplugged and replugged the connector without knowing it was the ignition relay

  44. Avataaar/Circle Created with python_avatars Joe Lucky says:

    Have a problem with a ford explorer sports track it spins but no sound of crank or spark any idea wat could be the issue

  45. Avataaar/Circle Created with python_avatars James Eddy says:

    Changed many gm ignition switches in that Era. One Gran Prix only took a quick smack on the colume to get it to start.

  46. Avataaar/Circle Created with python_avatars MacGyver 2 says:

    I like how logically you you diagnose problems. Good job.

  47. Avataaar/Circle Created with python_avatars Bobby House says:

    Thank you for all the help u have gave me it has help me a lot

  48. Avataaar/Circle Created with python_avatars Bobby House says:

    Thank you for all the help u have gave me it has help me a lot

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.